Mike Taulty's Blog
Bits and Bytes from Microsoft UK
Deploying Avalon Express (XAPP) Applications with the WinFX CTP B1 RC

Blogs

Mike Taulty's Blog

Elsewhere

Archives

I'm sure this is a FAQ but I didn't find it.
 
If you want to deploy Avalon Express applications from your IIS server then you need to register a bunch of MIME types.
 
There's a script in the WinFX B1 RC documentation that you can run to get this done. A very similar script can be found online here (http://winfx.msdn.microsoft.com/library/default.asp?url=/library/en-us/wcp_conceptual/winfx/appcore/overviews/BuildDeploy_IIS_MIME_Types.asp) and Tim recently pointed to it from his blog here (http://blogs.msdn.com/tims/archive/2005/07/01/434771.aspx).
 
I spent ages today because the script in the SDK docs is different from the one that's online and (as far as I can see) the one in the SDK docs has a bug in it.
 
My recommendation - use the online script. Ignore the one in the SDK.
 
I found it quite difficult to debug this thing so I thought I'd mention how I finally worked it out. I was in a weird situation where I could run .XAPP files from the public internet but not from my local server.
 
I downloaded the HTTP Filtering tool "Proximotron" from the web, I've used this in the past. I switched off all its filtering capabilities and reconfigured my browser to use Proximotron as a proxy. Proximotron is great because it can log all the HTTP traffic that's going through it.
 
I then pointed my browser at a .XAPP application on the internet that worked for me. Captured the traffic from this. Then I pointed my browser at a local .XAPP application and captured the traffic for that. Then did a quick compare and contrast.
 
I noticed that for my local version the MIME type coming back was;
 
  application/application/x-ms-xapp
 
which is wrong (one too many /applications in there). Then it was fixable.
 
 

Posted Fri, Jul 22 2005 3:13 AM by mtaulty

Comments

rimonabantexcellence site title wrote rimonabantexcellence site title
on Thu, May 23 2013 5:48 PM

Pingback from  rimonabantexcellence site title